RSS Bandit v1.8.0.862 Release

Monday, November 03 2008; by dareo - Release Notes

The recent release of RSS Bandit (v1.8.0.855) contained a bug which caused users to lose their feed lists on upgrading. This version fixes that bug.  Please download it from http://downloads.sourceforge.net/rssbandit/RssBandit1.8.0.862_installer.zip

The release notes for this version are the same as for the previous release.

 

#1 Ray on 11.03.2008 at 3:31 AM

No joy! I installed 855 on my Windows XP SP3 Home machine. As you said, it didn't recognize my feeds (though it didn't lose them either, the rssbandit directly in Documents and Settings was still there.) I then uninstalled 855 (had to, installer said 855 and 861 were same version) and installed 861. Same result - no feeds listed in My Feeds. RSS Bandit Help\About... reports current version is 861.

#2 Ray on 11.03.2008 at 3:37 AM

P.S. I originally upgraded from 1.6.0.2 to 1.8.0.855; feeds were visible in 1.6.0.2.

#3 Jamie on 11.03.2008 at 3:45 AM

@Ray: Look at the comments for the previous release and try to import the Subscriptions.xml file. It should restore your feeds.

#4 Jamie on 11.03.2008 at 3:49 AM

I installed the 855 build, and had my feeds disappear (later resurrected via import). However, there are still two things with 1.8 that I'm very unhappy about:

* On Vista (x64), the vertical space between items in the feed tree is huge. In 1.6 I used to have all my feeds showing without scrolling. I can now only see around half on screen at once.

* My local feed list no longer loads up properly on startup. The number of unread posts does not show until I either click on or update a feed.

#5 dareo on 11.03.2008 at 8:13 AM

Ray,

Please grab version 1.8.0.862 above and it should address your issues. I apologize for all the problems.

#6 Robin Capper on 11.03.2008 at 8:24 AM

The .862 release can not read the rssbandit-state.zip exported from Pheonix Release candidate

It can also not read it's own rssbandit-state.zip created using Tools upload/download feed. Get a dialog;

Feedlist download failed

Error...

My feedstate us stored locally in; C:\Mesh_Local\General\RSS Bandit Remote Storage

#7 Robin Capper on 11.03.2008 at 8:25 AM

Should add the feedlist exported from Phoenix RC was loaded correctly.

#8 dareo on 11.03.2008 at 8:40 AM

Robin,

Can you look at your trace.log or error.log files to see if there are any corresponding entries that match the failures you've seen?

#9 Iain on 11.03.2008 at 11:02 AM

I've lost all my feeds, but I can't find subscriptions.xml in C:\Users\<user>\AppData\Roaming\RssBandit

I'm on vista upgraded from the phoenix beta.

Does this mean they're just gone?

#10 Ray on 11.03.2008 at 2:11 PM

Just upgraded from 861 to 862. Feeds are now visible and updated as in 1.6.0.2. Two comments about the upgrade process:

1. 861 was installed but program directory wasn't deleted from Program Files and was locked until reboot. (I installed 862 to a different directory than 861.)

2. Lost custom column formatting in Feed Details window. Some custom preferences may also have reset such as update frequency, but I'm not sure about that.

Up and running as before. Thanks!

#11 Dominik on 11.03.2008 at 5:41 PM

A problem similar to an old problem I once had is back after the update: The feeds still seem to be there (at least it tells me that it has 1082 feeds) and there are a lof of unread posts, but nothing shows up under the headline "Abonnements", even though it has "6505" in brackets after the title... (No I don't actually read all of these ;) )

Also the left navigation thing looks broken.

#12 Markup Dude on 11.03.2008 at 8:31 PM

Will it be possible to make a portable version?

To be able to download & carry Feeds in a thumb drive , for storing/future reading will be wonderful!! May be in that version a separate 'Storage Folder' can be created for storing news for longer duration, in the thumb-drive.

You know what i mean, i would like to have a dedicated 4/8 GB drive with all my necessary text documents, bookmarks plus important News Feeds which i can keep referring to later.

Please keep this as a feature REQUEST for future, though you might not be able to do this in near future :)

Best of luck.

#13 Cris McRae on 11.03.2008 at 8:52 PM

I installed 862 over a version (downloaded 10/30, not sure what version it was) and my feeds are not available. This does not fix the problem.

#14 hama on 11.04.2008 at 1:52 AM

Why was unable to see the <iframe>tag since version 1.6?

#15 torstenr on 11.04.2008 at 8:28 AM

Ray: Column formatting gets lost is intentional: we do not migrate that from 1.6.x. All other things inclusive update frequency have a migration path.

To clarify migration process: it runs only once (the first time any 1.8.x version was started, we remember that in the registry hive HKCU\Software\rssbandit.org\Settings\version.1.8 . Additionally we check for the existence of the new files used by v1.8. If they are not there and we run the first time, we migrate (from subscriptions.xml and also from the older feedlist.xml).

Revision 861 seems to lack support of tthe migration fix, so U really have to get the newest revision 862.

#16 Rene on 11.04.2008 at 1:25 PM

I also can't download rssbandit-state.zip from a ftp-site. uploading works fine. when I try to download, I get an error. Do you plan to release a hotfix for that?

#17 dareo on 11.04.2008 at 1:48 PM

What is the error? Can you look to see if there is an entry in trace.log or error.log that corresponds to the problem you are having?

#18 Munish Gupta on 11.04.2008 at 2:44 PM

Unfortunately even the latest version is a complete disaster. I installed it on top of the previous beta release (phoenix). I lost all my feeds. I then tried to reimport feeds using subscriptions.xml and I got them back but the "state" was lost and all my flagged items were lost. Then when trying to update everything it hung. I had to kill the process and everything was lost once again! I can email the logs to you if that helps.

#19 BobM on 11.04.2008 at 3:10 PM

I using rev 862, and it does not load the feed list. The status message says 'Loading feed list', but never changes. I can do an import of subscriptions.xml, but as the poster above mentions, the read status of the items does not get updated. The next time I do an import of the feed list I'm left with the same state as three days ago.

Thanks for the hard work guys.

#20 Rene on 11.04.2008 at 8:19 PM

Regarding the "can't download rssbadit-state.zip" error:

The error.log file is empty. No entries are written to the trace.log file, when I try to download the zip file. But I find a lot of other exceptions in the trace.log. Most of them something like "

Exception: System.ApplicationException

Message: Error encountered while serializing data into stream."

Can I send you the trace.log file by email?

#21 Antonio Luiz on 11.04.2008 at 8:46 PM

Preciso dessas noticias no site..ok

obrigado !!

#22 Stephen on 11.05.2008 at 10:02 AM

Possible workaround ....

I had the invisible feeds issue. I tried uninstalling and reinstalling but that didn't make any difference.

I deleted all feeds and then re-imported and they are now visible again.

#23 Stephen on 11.05.2008 at 1:24 PM

or not!

After an hour so I got an error and the feeds were no longer visible.

#24 Justausr on 11.05.2008 at 3:08 PM

The hard work you've put in shows up here and I want to tahnk you. I feel that this product is as good as or better than anything else out there. There are a few bugs that stop me from switching, but I will once these get fixed.

Again, terrific product and thanks for all your efforts.

#25 David on 11.05.2008 at 5:25 PM

I upgraded to this release on Windows XP and there's a serious memory leak which was not present before. It is using 1.7GB (yes, GB!) after running for 2 days.

#26 Justin on 11.06.2008 at 11:51 AM

where would this subscription.xml file be? i can't find it anywhere. and i upgraded directly from 1.6 something to 1.8.0.862 and

my feeds are all gone :(

#27 Justin on 11.06.2008 at 12:42 PM

turns out i didnt have 1.6.x installed, but 1.7.0.2

after uninstalling 1.8 and reinstalling 1.7.0.2 i have my feeds back which i now can export and upgrade to 1.8

#28 Jean-Louis on 11.06.2008 at 1:45 PM

After installing 1.8.0.862, I lost all my feeds like many other. However I keep a .opml copy of my feeds and was able to recuperate. That was 3 days ago. This morning, when I opened RSSBandit, no more feed again... I lost them overnight, surprisingly.

#29 dareo on 11.06.2008 at 2:25 PM

Due to some user interface changes we made in this release, it could look like you have lost all your feeds when in fact they are still there. More details in my blog post at rssbandit.org/.../your-feeds-aren

#30 Steve on 11.06.2008 at 5:01 PM

After installing 1.8.0.862, all feeds are lost. I can reimport the feeds but each time RSSBandit is closed and re-opened the feeds are lost again. The issue does not appear related to the user interface changes introduced.

#31 Iain on 11.06.2008 at 5:17 PM

I think release needs to be pulled. I've lost all my feeds. Found an old opml file and re-imported them. Now they're gone again! It's a great bit of software, but this release makes kittens cry.

#32 hugohilter on 11.07.2008 at 1:35 AM

I am angry, very angry! I have updated from 1.6 to 1.8.0.862.

1) all Feeds are away!

2) I imported the Feeds from FeedDemon.

3) I read the Feeds.

4) I close RSSBandit

5) I start RSSBandit new

6) all Feeds are away...

and so on, and so on!

Is that a new function? Every time i close RSSBandit he lost his memory?

Or is now a new chronological order?

Everytime i use Bandit i have to import the feeds? Everytime? That is a bad "new function".

And therefore i am angry, very angry...

Best regards, hugohilter from Germany

#33 Robin Capper on 11.07.2008 at 9:34 AM

Dare, re #6 have attached my error log to S.F. Tracker item #2218324. Hope it helps.

#34 scott sanders on 11.07.2008 at 6:22 PM

I lost my feeds when upgrading to version 1.8.0.862 as well (from the Phoenix release). To make things worse, I do not have a subscriptions.xml file on my computer to import! However, to make things better, I found a file called DirectAccess.4939.subscription in my AppData/Roaming/RssBandit directory. When I imported that file, I got all of my feeds back.. for now.

#35 Tomislav on 11.08.2008 at 1:11 AM

I have search folder. I defined new item formatting (check Use a custom formatter) but when I read article using search folder formatting isn't custom but default (outlook-orange). Any hint how to fix that?

#36 Sergei on 11.08.2008 at 3:38 AM

..guess time to look for a new substitute to RSS Bandit..any suggestions ?

#37 Kubrick77 on 11.09.2008 at 8:41 PM

Hi everybody,

I've had too some problems with the 1.8.0.862 Release (disappeared feed) but I've the solution : uninstall the previous version, and delete the RSS Bandit folders in Program Files AND Application Data.

Then, install the 1.8.0.862 Release.

#38 Tom on 11.09.2008 at 11:34 PM

When right clicking on 'My Feeds' and selecting 'mark all items read', it no longer marks items as read until you click on each category, at which time it marks only the feeds in that category as read.

#39 Justin on 11.10.2008 at 1:40 AM

this really is a horrible release. the alpha was working ok. maybe you should have released this one as a beta at most? wouldn't make everybody install it at once.

well.. i have switched to sage-too for now.

#40 Dare Obasanjo on 11.10.2008 at 3:21 AM

You have my apologies.

I'm trying to track down the root cause of the feeds-being-lost-on-restart problem. First question, can you look in C:\Documents and Settings\[username]\Application Data\RssBandit for the feedsources.xml file? If so can you look and see if it has an entry that looks something like

<source name="My Feeds" ordinal="2" id="4186" type="DirectAccess">

<properties />

</source>

The id value should be different on your machine. Then can you see if you have a DirectAccess.<id>.subscriptions file in that folder? If so, does the ID match that in feedsources.xml?

In addition, is there a subscriptions.xml file in that folder?

Finally can you provide your error.log and trace.log files from recently running the application so we can see if there are any errors that correspond to not being able to save the file.

#41 suzanne on 11.10.2008 at 4:38 AM

I had uninstalled rss bandit when it ate my feeds during upgrade. I saw it was fixed (supposedly) so I installed it again today as I didn't like the other readers I had tried. Well guess what? Upon restarting all the feeds I loaded in manually today are gone again and the software is stuck on "loading feedlist" again. Please help! I really like this reader the best out of all the ones I have tried. I want my feeds back as I use many of them for my internship for grad school...

#42 alphons on 11.10.2008 at 1:20 PM

Unpacked and Installed RssBandit1.8.0.862_installer.zip but all feeds are lost, so this is NOT a fix.

#43 ppit on 11.10.2008 at 1:37 PM

RssBandit1.8.0.862_installer.zip makes all feeds disappear. This is not an issue with the interface. It says "susbcribed feeds: 0" (but I used to have more than 100!

What is the solution to that? Any fix being investigated?

#44 Steve on 11.10.2008 at 3:10 PM

Dare, I've tested the latest RSS Bandit build 1.8.0.862 and reviewed the information you are requesting. The feedsources.xml file contains the id="62539" which matches a file named DirectAccess.62539.subscription. There is no subscription.xml file located in the directory. If you provide a means, I can upload the files along with the error.log (empty) and trace.log files for your review.

#45 Tomislav on 11.10.2008 at 3:42 PM

Upload feeds toFTP server work without problem. But when I try to download that same RSS Bandit state file I got error "Feedlist download failed with error: Closed.."

#46 Munish on 11.10.2008 at 7:15 PM

Regarding comment# 18. The id in my feedsources.xml file matched the one in the DirectAccess.id.subscription file. I do have a subscriptions.xml file in that folder as well. Hope this helps.

#47 ppit on 11.11.2008 at 6:35 AM

Tried RssBandit1.8.0.862, but the problem is the same, all feeds are gone.

#48 ppit on 11.11.2008 at 6:37 AM

Also 1.8.0.869 does not solve the problem.

#49 dareo on 11.11.2008 at 2:12 PM

ppit,

Can you look in your trace.log file to see if there is any error that occurs when it is loading your feed list?

#50 ppit on 11.11.2008 at 11:29 PM

trace.log file details posted here:

forum.rssbandit.org/.../topic.asp