RSS Bandit v1.8.0.855 Release

Sunday, November 02 2008; by dareo - Release Notes

UPDATE: This release contained a bug which caused users to lose their feed lists on upgrading from previous versions. Please download v1.8.0.870 from here instead.

The major new features and bug fixes since the last official release (v.1.6.0.2) are listed below.  
 
Download the installer from here
 
NEW FEATURES 
- Download manager for viewing pending podcasts/enclosures
- Ability to synchronize feeds with Google Reader, NewsGator Online and the Windows Common Feed List.
- Option to increase or decrease font size in reading pane

BUG FIXES 
- 2153584 FTP storage ignores path, always stores in root directory
- 1987359 System crashes while updating feeds
- 1974485 NewsItem copy content to clipboard only copy the link
- 1971987 Error on start: docs out of order (0 < 6 )
- 1967898 Application hangs on shut down due to search indexing
- 1965832 Exception when refreshing feeds
- 2014927 New feeds not downloaded
- 1933253 Continuously Downloading Enclosures
- 1883614 Javascript in feed content causes exceptions
- 1899299 Oldest unread message shown on alert window on new items
- 1915756 Program crash during close operation
- 1987359 System crashes while updating feeds
- 2096903 Toolbar crashes and replaced with Red X
- 1960767 Crashes on opening due to FIPS policy set on Windows Vista.

 

#1 Rob on 11.02.2008 at 5:10 PM

Installed and lost all of my feeds.

i should never have bothered updating

#2 Avner Kashtan on 11.02.2008 at 5:15 PM

Yup. And it won't read the rssbandit-state.zip file from 1.6 either. :(

#3 dareo on 11.02.2008 at 5:26 PM

Thanks for your prompt feedback. We are looking into both issues now.

#4 LongScaryName on 11.02.2008 at 5:57 PM

Yup, lost all my feeds too.....

#5 torstenr on 11.02.2008 at 6:10 PM

Rob, Avner: I opened a bug at SF (https://sourceforge.net/tracker2/?func=detail&aid=2216683&group_id=96589&atid=615248 ). Can you please provide your subscriptions.xml there as a attachment? That would really help tracking down the problem, thanks!

#6 dareo on 11.02.2008 at 6:10 PM

For those who have lost their feeds. Can you give us some details on which version of RSS Bandit you were running before installing?

#7 dareo on 11.02.2008 at 6:37 PM

Avner,

An issue with the rssbandit-state.zip file has been fixed. The problem was that selecting 'Upload Feeds' did not use your recent subscriptions. I couldn't find an issue with downloading the rssbandit-state.zip into the application.

#8 Svens on 11.02.2008 at 6:44 PM

runs well so far here, but as with the last RC I'm missing the favicons. Once they were visible but after a feedupdate sometimes there were gone on the Google Feeds. Any hint how to force RSSBandit to download/show the Favicons?

#9 dareo on 11.02.2008 at 6:57 PM

If you go to Tools->Options you can reset the option to download favicons which may force an update. Also manually refreshing feeds should also cause it to happen.

#10 John A Thomson on 11.02.2008 at 8:19 PM

Lost my feeds as well while upgrading from the previous version to this release. Got them back by importing the XML file here:

C:\Users\<username>\AppData\Roaming\RssBandit\subscriptions.xml

This is the Vista path so you Win 2000 and XP users will have to find the appropriate file on your systems by yourself.

Hope that helps someone.

A much bigger bug is my toolbars and menues are screwed! There is a big red cross where the toolbars should be showing. They are still there as right clicking or mousing over reveals appropriate responses. I've now undocked the toolbars and menus so I can continue to use this BUGGY version!

Note to RSSBandit devs: Feel free to contact me via email if you need more information or screenshots of the problems.

Regards

John

#11 SvenS on 11.02.2008 at 8:23 PM

gave it a try, but no favicons. I deleted the Google Web Feeds and inserted it again, refreshing all feeds (google sync works like a charm) but still no favicons. I guess I've seen something in the forum that the favicons are initially loaded after everything is downloaded, right? The files are in the cache directory, so download seems successfully.

#12 torstenr on 11.02.2008 at 9:13 PM

SvenS: the favicon thing is a bug. We will refresh the installer ASAP. For now, you should be able to get around that by setting the global refresh rate for feeds to 1, then wait a half minute after Bandit started up, then press "Refresh All".

For all other with the migration issue: this is a bug too and just fixed - await the refreshed installer soon. For now you can get around by importing your old subscriptions.xml as John wrote above.

#13 Frank R... on 11.02.2008 at 10:25 PM

Just installed 1.8.0.855. Don't seem to loose the feeds (the feed errors are accessible), but I can't open the My Feeds tab to display the tree. I also cannot open the Options dialog, and cannot download the feeds via WebDAV.

#14 ppit on 11.02.2008 at 10:39 PM

I upgraded from 1.6.0.2 to 1.8.0.855 and lost all my feeds. I reported the problem in the forum.

Being on the safe side, I waited a long time before upgrading to that new version, but I have been fooled...

New features include synchronisation with the outside world, but RSSBandit should make sure that it can read its own feed database across different versions ! !

#15 Maciej on 11.02.2008 at 11:05 PM

Same here, after upgrade from 1.6 all feeds [RSS and newsgroups] lost... Importing subscriptions.xml worked...

#16 dareo on 11.03.2008 at 12:31 AM

as torsten said we've tracked down the problem causing missing feeds and favicons not showing. I should have an updated installer available in two hours or so. would it be preferred if the fixed version automatically import the missing feeds or if we provide instructions as to how to import them manually?

#17 rondi on 11.03.2008 at 12:33 AM

I too tried 1.8 coming from 1.6. 1.8 doesn't know where the Feeds & Details are from 1.6. I used Export from 1.6 & Import into 1.8--It gets the Feed names, but no data except todays. I also posted on the forum in ppit's thread.

#18 rondi on 11.03.2008 at 12:35 AM

I can not Mark All Feeds Read (Ver 1.8) by right clicking on the "My Feeds" button at the top of the Feed Subscriptions column.

#19 dareo on 11.03.2008 at 8:14 AM

The problem with missing feed lists is resolved in the newest version at downloads.sourceforge.net/.../RssBandit1.8.0.

Sorry for all the problems.

#20 Dan on 11.03.2008 at 5:52 PM

Hi installed the latest version. Feeds are gone. Reimported. Restart. Feeds are gone again. It seems that on my machine it's not able to save the feed list. Any file/folder to delete to have a "clean" installation?

#21 dareo on 11.03.2008 at 5:58 PM

Dan,

Are you using the latest version - v1.8.0.862 ?

#22 SvenS on 11.03.2008 at 9:29 PM

Looks like the Favicons are now working with the latest version. Thanks for the quick fix...great work guys especially the Google Reader integration.

#23 Dan on 11.04.2008 at 9:03 AM

Yes, Dare: I'm using the latest version. I'll try to complete remove and reistall. I've upgraded from the previous beta build.

#24 Cedric DSilva on 11.07.2008 at 9:42 AM

no cmment

#25 khawaja on 11.25.2008 at 10:14 PM

comments